www.BinaryAlchemy.de :: View topic - shadow artifacts on shadow-catching objects
 SearchSearch   RegisterRegister  ProfileProfile   UsergroupsUsergroups   Log inLog in 
If you create a new post, please use a topic that describes your problem
Documento sin título
 
shadow artifacts on shadow-catching objects

 
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...?
View previous topic :: View next topic  
Author Message

goshone



Joined: 11 Oct 2006
Posts: 68
Location/Company/Country: hydraulx, Santa Monica

PostPosted: Tue Jun 22, 2010 1:30 am    Post subject: shadow artifacts on shadow-catching objects Reply with quote

I am getting a strange artifact when I try to cast shadows (to make a shadow pass) on objects in the scene. It looks like chunks or blocks are missing from the shadow pass, causing a flickering at the edge of the shadow from a casting object.

To clarify, I have foreground objects, and background objects, with a BA_volume inbetween. I am trying to cast a shadow from the volume, and of course have shadow casting turned off on the objects.

I am unable to post an image at the moment, but in the hopes of explaining my abstract description:

shadow casting path
Obj A -> BA_volume -> Obj B

Obj A and Obj B both have shadow casting turned off but receive shadows turned on.
Artifact appears in shadow cast from BA_volume onto Obj B. It seems to be only near the edge of Obj A.

I am still trying to figure this out but just hoping maybe someone has come across this before.
thanks

Gosh


edit* BTW, using a single directional light with raytrace shadows. Ray depth seems to be fine and cell size (which is the first thing I tried) is giving me very good results in the beauty renders. Using Maya 2010 on Fedora 8.

It is also happening on a flat plane w/o any foreground objects, so this get even stranger.
Back to top
View user's profile Send private message

goshone



Joined: 11 Oct 2006
Posts: 68
Location/Company/Country: hydraulx, Santa Monica

PostPosted: Tue Jun 22, 2010 1:51 am    Post subject: Reply with quote

I think I have narrowed it down to the ugly fact that caused it is a primary visibility flag on my render layer. Now, how to make a shadow pass without turning off primary visibility is definitely gonna be a challenge.

Imagine dust falling down a wall, and trying to generate a shadow pass for that. I haven't come across this before, so there may be an issue with shadows cast from an invisible object close to the shadow catcher, causing the shadow to actually be invisible within the bounding box of the invisible volume??? Just a random guess.
Back to top
View user's profile Send private message

goshone



Joined: 11 Oct 2006
Posts: 68
Location/Company/Country: hydraulx, Santa Monica

PostPosted: Tue Jun 22, 2010 1:59 am    Post subject: Reply with quote

OK, I was able to fix the main issue by setting 'per ray type' view = 0

I am still getting some blocky artifacts in the shadows. Now it looks like a wireframe of the voxelized bounding box is subtracted from the shadow, if that makes sense.
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Tue Jun 22, 2010 8:50 am    Post subject: Reply with quote

I know there is a bug in Mental Ray if you try to make a shadow-only layer for volumens with the Mental Ray visibility flags. Usally the volume disappears completely.
Ther workaround with the view density=0 and not touching the mental Ray visibility options is the only way at the Moment.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Tue Jun 22, 2010 8:59 am    Post subject: Reply with quote

Perhaps check the ray depth for shadows and view in the render settings.
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail

goshone



Joined: 11 Oct 2006
Posts: 68
Location/Company/Country: hydraulx, Santa Monica

PostPosted: Tue Jun 22, 2010 6:21 pm    Post subject: Reply with quote

Are you referring to the render globals? I have them set to a very high trace depth (Max Trace = 20, Shadows, Reflect and Refract = 10) and still no luck in getting rid of them. Also increasing cell size only reduces the 'wire' thickness, but does not eliminate it.

Maybe there is some other ray depth setting in the shader?

*edit* I noticed that when autovolume is enabled it greys out 'Raytracing' button and changes it to 'Raytracing controlled by autovolume'. Maybe this is why changing trace depth has no effect? I cranked volume samples to 20 but still no luck.
Back to top
View user's profile Send private message

schoenberger
Site Admin


Joined: 02 Mar 2005
Posts: 3786

PostPosted: Wed Jun 23, 2010 8:13 am    Post subject: Reply with quote

I will try to repto the issue with a few simple boxes, but last time I checked the shadow-only has been working right with the view density=0 settings.
Please recheck if all mental Ray visibility flags are enabled / set to the default values. (primary rays, refraction visibility, shadow caster, .... )
_________________
Holger Schönberger
Binary Alchemy - digital materialization
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    www.BinaryAlchemy.de Forum Index -> Shader Problems / How do I...? All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
 
Documento sin título
 



Powered by phpBB © 2001, 2002 phpBB Group



Number of shameful bots caught by Anti-Spam ACP: 1667